Completed
Database Maintenance

Starts
July 16, 2021 at 11:00 PM
Status
Resolved after about 2 hours
Affects
App
Realtime Collaboration
  • Completed
    July 17, 2021 at 12:38 AM

    Maintenance has completed successfully.

  • Planned
    July 16, 2021 at 11:00 PM

    We’ll be conducting a round of maintenance on Friday, July 16, between 4:00pm - 5:00pm, Pacific Time. (Check what that means in your local time here.)

    During this time, you will not be able to access the Padlet web or mobile apps.

    We are very sorry if that’s inconvenient for you. This maintenance makes Padlet faster, more reliable, and more user friendly.

    Please bear with us once again.