Completed
Database maintenance

Starts
March 25, 2022 at 11:00 PM
Status
Resolved after about 4 hours
Affects
App
Realtime Collaboration
  • Completed
    March 26, 2022 at 3:16 AM

    Maintenance has completed successfully.

  • In progress
    March 25, 2022 at 11:00 PM

    Maintenance is now in progress

  • Planned
    March 25, 2022 at 11:00 PM

    We’ll be conducting a round of maintenance on Friday, March 25, between 4:00pm - 6:00pm, Pacific Time. (Check what that means in your local time here.)

    During this time, you will not be able to access the Padlet web or mobile apps.

    We are very sorry if that’s inconvenient for you. This maintenance makes Padlet faster, more reliable, and more user friendly.

    Please bear with us once again.