Emergency maintenance for Realtime Collaboration
Scheduled for April 19, 2025 at 1:00 AM – 3:00 AM
Affects
Realtime Collaboration
Under maintenance from 1:00 AM to 3:00 AM
Completed
April 19, 2025 at 3:00 AMCompleted
April 19, 2025 at 3:00 AMMaintenance has completed successfully
In progress
April 19, 2025 at 1:00 AMIn progress
April 19, 2025 at 1:00 AMMaintenance is now in progress
Planned
April 19, 2025 at 1:00 AMPlanned
April 19, 2025 at 1:00 AMWe’ll be conducting a round of maintenance on Friday, Apr 18, between 6:00pm - 8:00pm, Pacific Time. (Check what that means in your local time here.)
During this time, realtime collaboration may be disrupted for you.
We are very sorry if that’s inconvenient for you. This maintenance makes Padlet's realtime more reliable.
Please bear with us once again.