Resolved
High latency when accessing Padlet

Started
February 08, 2024 at 6:10 PM
Status
Resolved after about 1 hour

Impact

Degraded performance
Affected
App
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    We are currently investigating this incident.