[Resolved] Padlet is not accessible

Started on January 12, 2021 at 5:21 PM. Resolved after 17 minutes

Affected

App
Realtime Collaboration
  • Investigating
    January 12, 2021 at 5:21 PM

    We are currently investigating this incident.

  • Identified
    January 12, 2021 at 5:32 PM

    We are able to address the problem and started working on a fix. Padlet can be accessed now, although it's very slow.

  • Resolved
    January 12, 2021 at 5:39 PM

    We just resolved the issue! Padlet is back!