Resolved
Padlet is inaccessible

Started
November 16, 2021 at 5:44 PM
Status
Resolved after 44 minutes
Affected
App
Realtime Collaboration

Impact

Partial outage
  • Resolved
    November 16, 2021 at 6:28 PM

    We just resolved the issue!

  • Monitoring
    November 16, 2021 at 6:25 PM

    Most of Padlet is back up. Users might have some issues loading images.

  • Investigating
    November 16, 2021 at 6:05 PM

    We are still investigating this incident. padlet.com and Backpack/Briefcase can be accessed, but parts of the service are still unusable.

  • Investigating
    November 16, 2021 at 5:44 PM

    We are currently investigating this incident.