Resolved
Padlet is inaccessible

Started
June 21, 2022 at 6:34 AM
Status
Resolved after 30 minutes
Affected
App
Realtime Collaboration

Impact

Major outage
  • Resolved
    June 21, 2022 at 7:04 AM

    Our network service provider is back online

  • Identified
    June 21, 2022 at 6:34 AM

    Our network service provider has an outage.