[Resolved] Padlet slowed down and is unreliable

Started on January 21, 2021 at 3:03 PM. Resolved after about 1 hour

Affected

App
Realtime Collaboration
  • Investigating
    January 21, 2021 at 3:03 PM

    We are currently investigating this incident.

  • Resolved
    January 21, 2021 at 4:11 PM

    We just resolved the issue!