Padlet - High latency when accessing Padlet – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
Dark mode
All systems operational
High latency when accessing Padlet
Resolved
Degraded performance
Started over 1 year ago
March 11, 2025
Lasted 17 minutes
10:17
10:33 AM
UTC
Affected
Boards
Operational from 10:17 AM to 10:33 AM
Updates
Resolved
March 11, 2025 at 10:33 AM
UTC
Resolved
March 11, 2025 at 10:33 AM
UTC
This incident has been resolved.
Investigating
March 11, 2025 at 10:17 AM
UTC
Investigating
March 11, 2025 at 10:17 AM
UTC
We are currently investigating this incident.
UTC
UTC
UTC
UTC
UTC